On 04.03.2014, at 09:42, Tanay Abhra <tanayabh@xxxxxxxxx> wrote: [...] > commit.c | 17 +++++++++-------- > 1 file changed, 9 insertions(+), 8 deletions(-) > > diff --git a/commit.c b/commit.c > index 6bf4fe0..6c92acb 100644 > --- a/commit.c > +++ b/commit.c [...] > @@ -566,14 +566,16 @@ static void record_author_date(struct author_date_slab *author_date, > buf; > buf = line_end + 1) { > line_end = strchrnul(buf, '\n'); > - if (!starts_with(buf, "author ")) { > + ident_line = skip_prefix(buf, "author "); > + if (!ident_line) { > if (!line_end[0] || line_end[1] == '\n') > return; /* end of header */ > continue; > } > + buf = ident_line; > if (split_ident_line(&ident, > - buf + strlen("author "), > - line_end - (buf + strlen("author "))) || > + buf, > + line_end - buf) || > !ident.date_begin || !ident.date_end) > goto fail_exit; /* malformed "author" line */ > break; Why not get rid of that assignment to "buf", and use ident_line instead of buf below? That seems like it would be more readable, wouldn't it? > @@ -1193,10 +1195,9 @@ static void parse_gpg_output(struct signature_check *sigc) > for (i = 0; i < ARRAY_SIZE(sigcheck_gpg_status); i++) { > const char *found, *next; > > - if (starts_with(buf, sigcheck_gpg_status[i].check + 1)) { > - /* At the very beginning of the buffer */ > - found = buf + strlen(sigcheck_gpg_status[i].check + 1); > - } else { > + found = skip_prefix(buf, sigcheck_gpg_status[i].check + 1); > + /* At the very beginning of the buffer */ Do we really need that comment, and in that spot? The code seemed clear enough to me without it. But if you think keeping is better, perhaps move it to *before* the skip_prefix, and add a trailing "?" > + if(!found) { > found = strstr(buf, sigcheck_gpg_status[i].check); > if (!found) > continue;
Attachment:
signature.asc
Description: Message signed with OpenPGP using GPGMail