In the original version of this function, "cp" acted as a pointer to many different things. Since the refactoring in the last patch, it only marks the at-sign in the string. Let's use a more descriptive variable name. Signed-off-by: Jeff King <peff@xxxxxxxx> --- Obviously can be squashed with the prior refactoring, but I think splitting it makes the diffs easier to read. sha1_name.c | 10 +++++----- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/sha1_name.c b/sha1_name.c index 5db742b..958aa2e 100644 --- a/sha1_name.c +++ b/sha1_name.c @@ -1117,7 +1117,7 @@ static int interpret_upstream_mark(const char *name, int namelen, */ int interpret_branch_name(const char *name, int namelen, struct strbuf *buf) { - char *cp; + char *at; int len = interpret_nth_prior_checkout(name, buf); if (!namelen) @@ -1132,15 +1132,15 @@ int interpret_branch_name(const char *name, int namelen, struct strbuf *buf) return reinterpret(name, namelen, len, buf); } - cp = strchr(name, '@'); - if (!cp) + at = strchr(name, '@'); + if (!at) return -1; - len = interpret_empty_at(name, namelen, cp - name, buf); + len = interpret_empty_at(name, namelen, at - name, buf); if (len > 0) return reinterpret(name, namelen, len, buf); - len = interpret_upstream_mark(name, namelen, cp - name, buf); + len = interpret_upstream_mark(name, namelen, at - name, buf); if (len > 0) return len; -- 1.8.5.2.500.g8060133 -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html