The first patch of this series is a start on replacing the deprecated OPT_BOOLEAN macro by OPT_BOOL. All occurences have been reviewed so far, only 140 occurences to go. The 3 patches after the first are things I noticed during the review for the macro replacement. These should ease readability. I'll continue replaceing macros the next days, this series is for review only. Stefan Beller (4): Replace deprecated OPT_BOOLEAN by OPT_BOOL log, format-patch: also accept short parameter 'q' to be quiet checkout: remove superfluous local variable name-rev: ease up condition builtin/check-attr.c | 8 ++++---- builtin/checkout.c | 22 ++++++++++------------ builtin/clone.c | 16 ++++++++-------- builtin/fsck.c | 16 ++++++++-------- builtin/grep.c | 36 ++++++++++++++++++------------------ builtin/log.c | 14 +++++++------- builtin/ls-tree.c | 6 +++--- builtin/merge-file.c | 2 +- builtin/merge.c | 12 ++++++------ builtin/mv.c | 2 +- builtin/name-rev.c | 14 +++++++------- builtin/notes.c | 4 ++-- builtin/replace.c | 6 +++--- builtin/reset.c | 2 +- builtin/rev-parse.c | 4 ++-- 15 files changed, 81 insertions(+), 83 deletions(-) -- 1.8.4.rc0.1.g8f6a3e5 -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html