Torsten Bögershausen <tboegi@xxxxxx> writes: >> +++ b/diff.c >> @@ -2647,6 +2647,10 @@ static int diff_populate_gitlink(struct diff_filespec *s, int size_only) >> int diff_populate_filespec(struct diff_filespec *s, int size_only) >> { >> int err = 0; >> + enum safe_crlf crlf_warn = (safe_crlf != SAFE_CRLF_FAIL >> + ? safe_crlf >> + : SAFE_CRLF_WARN); > > Thanks, > Does it makes sense to write it the other way around? > > enum safe_crlf crlf_warn = (safe_crlf == SAFE_CRLF_FAIL > ? SAFE_CRLF_WARN > : safe_crlf); I didn't see much difference either way, but between "FAIL needs to be demoted to WARN, everything else goes as-is" and the original "We do not care about anything other than FAIL, so use it as-is, but demote FAIL to WARN", yours look shorter. Will replace. -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html