From: Célestin Matte <celestin.matte@xxxxxxxxxx> A new version of this series of patch, to make it mergeable with next. Changes with v5: - Fix a bug in [21/31] - Build on top of next so that it's mergeable Changes with v4: - fixed typos - Change in [21/31]: all the processing is done within the subroutine Changes with v3: - Remove whitespace in [18/28] - Typo in [09/28] - Better line split in [22/28] - A part of the file @@ -610,9 +610,9 @@ had escaped patches [22/31] and [23/31] for some reason. This is fixed. - patch [29/31] and [30/31] are new: they add a .perlcriticrc file to ignore some rules and add a rule in the Makefile for perlcritic - patch [31/31] is also a new one, which intends to make some error messages more precise. It comes from an advice from es in the reviewing of v1, that I had forgotten to add in earlier versions. It is not related to perlcritic, but I hope it can be included into this series of patches anyway. Changes with v2: - Remove patch [02/22] about using the Readonly module - Split commit [07/22] into 5 different ones - Split commit [14/22] into 2 different ones - Patch [17/22] was *not* split: tell me if it is necessary - Remove wrong change in patch [22/22] Changes with v1: - split first commit into 6 different commits - remove commit [17/18] about moving open() call - took every other comment into account Célestin Matte (31): git-remote-mediawiki: Make a regexp clearer git-remote-mediawiki: Move "use warnings;" before any instruction git-remote-mediawiki: Replace :utf8 by :encoding(UTF-8) git-remote-mediawiki: Always end a subroutine with a return git-remote-mediawiki: Move a variable declaration at the top of the code git-remote-mediawiki: Change syntax of map calls git-remote-mediawiki: Rewrite unclear line of instructions git-remote-mediawiki: Remove useless regexp modifier (m) git-remote-mediawiki: Change the behaviour of a split git-remote-mediawiki: Change separator of some regexps git-remote-mediawiki: Change style in a regexp git-remote-mediawiki: Change style in a regexp git-remote-mediawiki: Add newline in the end of die() error messages git-remote-mediawiki: Change the name of a variable git-remote-mediawiki: Turn double-negated expressions into simple expressions git-remote-mediawiki: Remove unused variable $entry git-remote-mediawiki: Rename a variable ($last) which has the name of a keyword git-remote-mediawiki: Assign a variable as undef and make proper indentation git-remote-mediawiki: Check return value of open git-remote-mediawiki: remove import of unused open2 git-remote-mediawiki: Put long code into a subroutine git-remote-mediawiki: Modify strings for a better coding-style git-remote-mediawiki: Brace file handles for print for more clarity git-remote-mediawiki: Replace "unless" statements with negated "if" statements git-remote-mediawiki: Don't use quotes for empty strings git-remote-mediawiki: Put non-trivial numeric values in constants. git-remote-mediawiki: Fix a typo ("mediwiki" instead of "mediawiki") git-remote-mediawiki: Clearly rewrite double dereference git-remote-mediawiki: Add a .perlcriticrc file git-remote-mediawiki: add a perlcritic rule in Makefile git-remote-mediawiki: Make error message more precise contrib/mw-to-git/.perlcriticrc | 28 ++ contrib/mw-to-git/Makefile | 2 + contrib/mw-to-git/git-remote-mediawiki.perl | 537 +++++++++++++++------------- 3 files changed, 320 insertions(+), 247 deletions(-) create mode 100644 contrib/mw-to-git/.perlcriticrc -- 1.8.3.rc3.49.g4e74807 -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html