Change object_array and object_array_entry to copy the name before storing it in the name field, and free it when an entry is deleted from the array. This is useful because some of the name strings passed to add_object_array() or add_object_array_with_mode() are refnames whose lifetime is not defined by the refs API (and which we want to shorten). Signed-off-by: Michael Haggerty <mhagger@xxxxxxxxxxxx> --- This is the culmination of the last few commits. Since some callers want to store refnames in the name field of object_array elements, but we don't want those callers to assume that the refnames that they got from for_each_ref() have infinite lifetime, the easiest thing to do is have object_array make a copy of the names before writing them in the entries, and to free the names for entries that are no longer in use. This change fixes the problem, but has some disadvantages: * It requires extra copies to be made of strings that are already copies, for example when the results of path_name(path, name) are used as a name in revision.c:add_object(). This might be rare enough that it can be ignored (though the original result of path_name() would have to be freed, which this patch doesn't do so there is a memory leak). * Many callers store the empty string ("") as the name; for example, most of the entries created during a run of rev-list have "" as their name. This means that lots of needless copies of "" are being made. I think that the best solution to this problem would be to store NULL rather than "" for such entries, but I haven't figured out all of the places where the name is used. The alternative would be to have callers make the copies if necessary *before* passing the names into add_object_array(), and themselves ensure that those copies get freed sometime. This would be more work: effectively each object_array would have to have its own memory ownership policy and we would have to figure out exactly where in the code entries are added and removed from particular lists. Since I'm not too clear on what these names are used for, how many object_array entries are created in different scenarios, etc., I decided to submit this patch as an RFC to get some feedback before I work on a final solution. object.c | 6 +++++- object.h | 6 +++++- 2 files changed, 10 insertions(+), 2 deletions(-) diff --git a/object.c b/object.c index 10b5349..a678c1b 100644 --- a/object.c +++ b/object.c @@ -273,7 +273,7 @@ void add_object_array_with_mode(struct object *obj, const char *name, struct obj array->objects = objects; } objects[nr].item = obj; - objects[nr].name = name; + objects[nr].name = name ? xstrdup(name) : NULL; objects[nr].mode = mode; array->nr = ++nr; } @@ -289,6 +289,8 @@ void object_array_filter(struct object_array *array, if (src != dst) objects[dst] = objects[src]; dst++; + } else { + free(objects[src].name); } } array->nr = dst; @@ -319,6 +321,8 @@ void object_array_remove_duplicates(struct object_array *array) if (src != array->nr) objects[array->nr] = objects[src]; array->nr++; + } else { + free(objects[src].name); } } } diff --git a/object.h b/object.h index 6c1c27f..f2c503a 100644 --- a/object.h +++ b/object.h @@ -11,7 +11,11 @@ struct object_array { unsigned int alloc; struct object_array_entry { struct object *item; - const char *name; + /* + * name or NULL. If non-NULL, the memory pointed to + * is owned by this object. + */ + char *name; unsigned mode; } *objects; }; -- 1.8.2.3 -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html