Ramkumar Ramachandra <artagnon@xxxxxxxxx> writes: > +finish_rebase () { > + if test -f "$state_dir/autostash" > + then > + stash_sha1=$(cat "$state_dir/autostash") > + if git stash apply $stash_sha1 2>&1 >/dev/null > + then > + echo "Applied autostash" > + else > + ref_stash=refs/stash && > + : >>"$GIT_DIR/logs/$ref_stash" && > + git update-ref -m "autostash" $ref_stash $stash_sha1 \ > + || die "$(eval_gettext 'Cannot store $stash_sha1')" && > + echo " > +$(gettext 'Applying autostash resulted in conflicts. > +... This is confusing (or confused): these && might && fail || die && success It is much easier to read if you just drop && after die and write it like so: ref_stash=refs/stash && : >>"$GIT_DIR/logs/$ref_stash" && git update-ref -m "autostash" $ref_stash $stash_sha1 || die "$(eval_gettext 'Cannot store $stash_sha1')" echo "... success message comes here..." -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html