Re: [PATCH 1/3] Make read_index_data() public

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Fri, Apr 12, 2013 at 07:26:11PM +0200, Lukas Fleischer wrote:

> This allows for reusing the function in convert.c later.
> 
> Also, move it from attr.c to read-cache.c and add a use_index parameter
> to specify a custom index_state since we are no longer enable to access
> the static use_index variable from attr.c.

I'm all for removing duplicated code, but, but I think the name
"read_index_data" is a bit misleading for a global function. I would
expect it to read data from the index (and the argument "path" does not
help clarify that at all).

Can we rename it read_blob_data_from_index_path() or something?

-Peff
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]