Brandon Casey wrote: > Teach append_signoff how to detect a duplicate s-o-b in the commit footer. > This is in preparation to unify the append_signoff implementations in > log-tree.c and sequencer.c. [...] > --- a/sequencer.c > +++ b/sequencer.c > @@ -1082,9 +1101,10 @@ int sequencer_pick_revisions(struct replay_opts *opts) > return pick_commits(todo_list, opts); > } > > -void append_signoff(struct strbuf *msgbuf, int ignore_footer) > +void append_signoff(struct strbuf *msgbuf, int ignore_footer, int no_dup_sob) Isn't the behavior of passing '1' here just a bug in "format-patch -s"? Style: callers will be easier to read if the function takes a flag word with named bits, as in: #define APPEND_SIGNOFF_DEDUP (1 << 0) void append_signoff(..., int ignore_footer, unsigned flag) -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html