On Fri, Aug 03, 2012 at 09:57:15PM +0200, Michał Kiedrowicz wrote: > Jeff King wrote: > > The seq command is GNU-ism, and is missing at least in older BSD > releases and their derivatives, not to mention antique > commercial Unixes. > > We already purged it in b3431bc (Don't use seq in tests, not > everyone has it, 2007-05-02), but a few new instances have crept > in. They went unnoticed because they are in scripts that are not > run by default. > > This commit replaces them with test_seq that is implemented with a Perl > snippet (proposed by Jeff). This is better than inlining this snippet > everywhere it's needed because it's easier to read and it's easier to > change the implementation (e.g. to C) if we ever decide to remove Perl > from the test suite. > > Note that test_seq is not a complete replacement for seq(1). It just > has what we need now. > > There are also many places that do `for i in 1 2 3 ...` but I'm not sure > if it's worth converting them to test_seq. That would introduce running > more processes of Perl during the tests and might increase the total > time tests take. > > Signed-off-by: Michał Kiedrowicz <michal.kiedrowicz@xxxxxxxxx> Fine explanation, but... > diff --git a/t/perf/perf-lib.sh b/t/perf/perf-lib.sh > index 5580c22..a1361e5 100644 > --- a/t/perf/perf-lib.sh > +++ b/t/perf/perf-lib.sh > @@ -163,7 +163,7 @@ test_perf () { > else > echo "perf $test_count - $1:" > fi > - for i in $(seq 1 $GIT_PERF_REPEAT_COUNT); do > + for i in $(test_seq 1 $GIT_PERF_REPEAT_COUNT); do Two args to test_seq, but... > +# test_seq is a portable replacement for seq(1). > +# It may be used like: > +# > +# for i in `test_seq 100`; do > +# echo $i > +# done > + > +test_seq () { > + test $# = 1 || > + error "bug in the test script: not 1 parameter to test_seq" > + last=$1 > + "$PERL_PATH" -le "print for 1..$last" > +} it wants only one. I think you would want: test $# = 1 && set -- 1 "$@" "$PERL_PATH" -le "print for $1..$2" It might also be worth quoting the parameters like this: "$PERL_PATH" -le "print for '$1'..'$2'" so that "test_seq a f" works, too. -Peff -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html