[PATCH v3 0/9] Extending the shelf-life of "git describe" output

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



This is take 3.  The earlier rounds were $gmane/200165 and 200387.

Only the [9/9] is different.  It adds a test that creates a history
with many objects whose names share the same prefix, and tries to
check how the implementation employs various possible
disambiguations, e.g.

 (1) "$tagname-$generation-g$shortname" can only name a commit
     object, which is the topic of this series;

 (2) "$shortname" in "$tagname-$generation-g$shortname" alone may
     not be sufficiently unambiguous to name a commit, but there may
     be only one such commit if we take $tagname and $generation
     into account, which I hinted as a possible enhancement in the
     cover letter of the first round of this series;

 (3) "$shortname" in "$shortname:$path" can only name a tree-ish,
     which Thomas volunteered to build on top of this series;

 (4) "$shortname" in "$shortname^0" and "$shortname^{commit}" can
     only name a commit-ish, which is a natural extension of (3);

 (5) "$shortname" in "$shortname^0" and "$shortname^{commit}" might
     name more than one commit-ish, but when they are peeled to
     commits, they may name the same one (e.g. one is the commit,
     the other is a tag to the commit), which is a natural extension
     of (4).

Currently, the code implements only (1) and all other tests are
marked as test_expect_failure.

Junio C Hamano (9):
  sha1_name.c: indentation fix
  sha1_name.c: clarify what "fake" is for in
    find_short_object_filename()
  sha1_name.c: rename "now" to "current"
  sha1_name.c: refactor find_short_packed_object()
  sha1_name.c: correct misnamed "canonical" and "res"
  sha1_name.c: restructure disambiguation of short names
  sha1_name.c: allow get_short_sha1() to take other flags
  sha1_name.c: teach get_short_sha1() a commit-only option
  sha1_name.c: get_describe_name() by definition groks only commits

 sha1_name.c                         | 282 +++++++++++++++++++++++-------------
 t/t1512-rev-parse-disambiguation.sh | 172 ++++++++++++++++++++++
 2 files changed, 354 insertions(+), 100 deletions(-)
 create mode 100755 t/t1512-rev-parse-disambiguation.sh

-- 
1.7.11.1.29.gf71be5c
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]