On Thu, Jun 21, 2012 at 8:35 AM, Junio C Hamano <gitster@xxxxxxxxx> wrote: > Signed-off-by: Junio C Hamano <gitster@xxxxxxxxx> > --- > sha1_name.c | 3 ++- > 1 file changed, 2 insertions(+), 1 deletion(-) > > diff --git a/sha1_name.c b/sha1_name.c > index 58dbbe2..15e97eb 100644 > --- a/sha1_name.c > +++ b/sha1_name.c > @@ -606,6 +606,7 @@ static int peel_onion(const char *name, int len, unsigned char *sha1) > static int get_describe_name(const char *name, int len, unsigned char *sha1) > { > const char *cp; > + unsigned flags = GET_SHORT_QUIETLY | GET_SHORT_COMMIT_ONLY; > > for (cp = name + len - 1; name + 2 <= cp; cp--) { > char ch = *cp; > @@ -616,7 +617,7 @@ static int get_describe_name(const char *name, int len, unsigned char *sha1) > if (ch == 'g' && cp[-1] == '-') { > cp++; > len -= cp - name; > - return get_short_sha1(cp, len, sha1, GET_SHORT_QUIETLY); > + return get_short_sha1(cp, len, sha1, flags); Is there a reason why you chose to put the definition in the root-scope of the function? There's an excellent opportunity just a few lines above the only place it's used, and I suspect it would increase readability to put it there... -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html