Erik Faye-Lund <kusmabite@xxxxxxxxx> a écrit :
Well, I've always been slightly annoyed by the "send-mail" vs
"sendemail" inconsistency. Perhaps we could do something along these
lines (plus all documentation-updates, omitted for clarity) to reduce
the risk of confusion?
Yeah, the leaking of $identity between different sections is a bit
suboptimal, but as a fallback-mechanism I don't think it actually
matters much.
[...]
-# read configuration from [sendemail "$identity"], fall back on [sendemail]
+# read configuration from [sendmail "$identity"], fall back on [sendmail]
+$identity = Git::config(@repo, "sendmail.identity") unless (defined
$identity);
+read_config("sendmail.$identity") if (defined $identity);
+read_config("sendmail");
+# same as above, but with legacy "sendemail"
$identity = Git::config(@repo, "sendemail.identity") unless (defined
$identity);
read_config("sendemail.$identity") if (defined $identity);
read_config("sendemail");
I'm not very familiar with perl, but do you mean to replace "sendemail" by
"sendmail" or just make "sendmail" usable in the config file, along with
"sendemail" ?
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html