Brian Gernhardt <brian@xxxxxxxxxxxxxxxxxxxxx> writes: > On OS X 10.7.3, I get the following error attempting to build next: > > CC test-mergesort.o > In file included from test-mergesort.c:2: > ./mergesort.h:4:7: error: conflicting types for 'mergesort' > void *mergesort(void *list, > ^ > /usr/include/stdlib.h:306:6: note: previous declaration is here > int mergesort(void *, size_t, size_t, > ^ > > This appears to be due to the fact that 0db71e0: "add mergesort() for > linked lists" added a mergesort implementation with a different > signature than a mergesort implemented by OS X's standard library. Unfortunate. OS X shouldn't contaminate the user namespace by adding such names in stdlib.h (which incidentally has qsort()), but the damage is done already, so I am not opposed to rename it to llist_mergesort() or something. -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html