Zbigniew Jędrzejewski-Szmek <zbyszek@xxxxxxxxx> writes: > diff --git a/t/t1507-rev-parse-upstream.sh b/t/t1507-rev-parse-upstream.sh > index 1342915..a00b689 100755 > --- a/t/t1507-rev-parse-upstream.sh > +++ b/t/t1507-rev-parse-upstream.sh > @@ -135,7 +135,7 @@ test_expect_success 'branch@{u} error message when no upstream' ' > > test_expect_success '@{u} error message when no upstream' ' > cat >expect <<-EOF && > - error: No upstream branch found for ${sq}${sq} > + error: No upstream branch found for ${sq}master${sq} > fatal: Needed a single revision > EOF > test_must_fail git rev-parse --verify @{u} 2>actual && I am not sure if saying "... for 'master'" is better or "... for the current branch" is better. Using different wording reflects the fact that the user gave "@{u}" and not "master@{u}". But I do not care too deeply. Either way, it is a vast improvement over the current "... for ''" output. And the "detached" case is definitely better. > @@ -153,7 +153,7 @@ test_expect_success 'branch@{u} error message with misspelt branch' ' > > test_expect_success '@{u} error message when not on a branch' ' > cat >expect <<-EOF && > - error: No upstream branch found for ${sq}${sq} > + error: HEAD does not point to a branch > fatal: Needed a single revision > EOF Thanks. -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html