Ramkumar Ramachandra wrote: > Hi Jonathan, > > I wrote a new commit message for this patch. Perhaps it can help clarify? Thanks. > revert: decouple sequencer actions from commands > > Currently, we have two actions "pick" and "revert" that directly > correspond to the action of the commands 'git cherry-pick' and 'git > revert' respectively. Well, let's start here. The two insns "pick" and "revert" and the ability to mix them doesn't have much to do with the picture, does it? I think the actual problem being solved is that insn types, as described by the replay_action enum, are being abused to refer to top-level git commands "revert" and "cherry-pick". The sequencer isn't supposed to care which top-level git command called it, except in some messages, so we'd certainly like to stop pretending that has something to do with insn types. Based on what you've said, correcting this cleanly is complicated in some places by the inconvenient fact that the sequencer _does_ care which top-level git command called it. (I haven't checked this; I'm just taking it on faith from you.) If we want to let other git commands (like "git rebase" or "git sequence") call into the sequencer, that sounds like a way bigger problem than any conflict of terminology. -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html