Carlos Martín Nieto <cmn@xxxxxxxx> writes: > On Mon, Nov 07, 2011 at 11:26:42AM -0500, Jeff King wrote: > ... >> The patch to do "D"eleted is pretty simple: >> >> diff --git a/read-cache.c b/read-cache.c >> index dea7cd8..cc1ebdf 100644 >> --- a/read-cache.c >> +++ b/read-cache.c >> @@ -1103,9 +1103,11 @@ int refresh_index(struct index_state *istate, unsigned int flags, const char **p >> int in_porcelain = (flags & REFRESH_IN_PORCELAIN); >> unsigned int options = really ? CE_MATCH_IGNORE_VALID : 0; >> const char *needs_update_fmt; >> + const char *needs_rm_fmt; >> const char *needs_merge_fmt; >> >> needs_update_fmt = (in_porcelain ? "M\t%s\n" : "%s: needs update\n"); >> + needs_rm_fmt = (in_porcelain ? "D\t%s\n" : "%s: needs update\n"); >> needs_merge_fmt = (in_porcelain ? "U\t%s\n" : "%s: needs merge\n"); > > While the name fits in with the rest of the variables, it's kind of > the wrong way around, isn't it? It doesn't need an 'rm', it /was/ > rm'd. The variable names were chosen to mean "In a situation where the plumbing traditionally would have said X, use this format to describe it". This is the first topic to separate a single situation (from the plumbing's point of view) into two and say different things at Porcelain, and the variable naming no longer works. An obvious solution would be to rename all of them to be based on "what happened to the path". E.g. "modified_fmt" would be set to either "M" or "needs update", and "removed_fmt" would be set to either "D" or "needs update", etc. -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html