Michael Haggerty <mhagger@xxxxxxxxxxxx> writes: > Patch series re-roll: Thanks for working on this. I very much like the general direction of the series, the strategy to avoid wholesale audit of the callers and marking the places that needs fixing with "_unsafe()". There were a few minor things that looked worth mentioning while reviewing, though. - (style) You seem to be fond of pre-increment a lot, but in general our codebase prefers post-increment especially when the end result does not make any difference, e.g. for (i = 1; ...; ++i) { ... - (series structure) It might make the series progress easier to follow if you introduced check_ref_format_unsafe() in the same commit where you change check_ref_format() to take flags parameter. -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html