On Wed, Aug 17, 2011 at 11:44:32AM -0700, Junio C Hamano wrote: > At least "pager.stash.list" should be spelled as "pager.stashList" or > something. It is not like there are multitude of arbigrary choices that > may match "pager.*.list" pattern. The pager code would then assume that was for a command "stashlist". It probably doesn't matter in practice, but I think it's a little nicer to keep the namespace properly separated unless there is a good reason not to. There are other places where something like this might be handy, too. For example, auto-pagination of "git branch" or "git tag -l" (but you wouldn't want to paginate "git branch foo"). > Also a variable can be set to false by setting it to 0, no, etc., so > you need to inspect it with "git config --bool" to get the canonical > version of its value. > > What's so difficult to say "git stash list | less" or even "git -p > stash list"? Couldn't one make the same argument about git's entire use of the pager? Anyway, I think his problem is not "I want a pager but I am too lazy to type it", but rather that "git stash list" will auto-paginate by default, because it is chaining to "log", which auto-paginates. You can turn it off with "--no-pager", but pager.stash seems to have no effect. -Peff -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html