Hi, This is yet another iteration, with few improvements since last time. Some minor nits pointed out by Jonathan and Christian are now fixed. One additional detail: while playing with my generalized sequencer, I noticed a couple of embarrassing bugs in the tests -- "malformed instruction sheet 1" and "malformed instruction sheet 2" were picking "base..picked" instead of "base..anotherpick". Fixed now. Thanks. -- Ram Ramkumar Ramachandra (18): advice: Introduce error_resolve_conflict config: Introduce functions to write non-standard file revert: Simplify and inline add_message_to_msg revert: Don't check lone argument in get_encoding revert: Rename no_replay to record_origin revert: Eliminate global "commit" variable revert: Introduce struct to keep command-line options revert: Separate cmdline parsing from functional code revert: Don't create invalid replay_opts in parse_args revert: Save data for continuing after conflict resolution revert: Save command-line options for continuing operation revert: Make pick_commits functionally act on a commit list revert: Introduce --reset to remove sequencer state reset: Make reset remove the sequencer state revert: Remove sequencer state when no commits are pending revert: Don't implicitly stomp pending sequencer operation revert: Introduce --continue to continue the operation revert: Propagate errors upwards from do_pick_commit Documentation/git-cherry-pick.txt | 6 + Documentation/git-revert.txt | 6 + Documentation/sequencer.txt | 9 + Makefile | 2 + advice.c | 31 ++- advice.h | 3 +- branch.c | 2 + builtin/revert.c | 735 +++++++++++++++++++++++++++++-------- cache.h | 2 + config.c | 36 ++- sequencer.c | 19 + sequencer.h | 20 + t/7106-reset-sequence.sh | 44 +++ t/t3510-cherry-pick-sequence.sh | 214 +++++++++++ 14 files changed, 958 insertions(+), 171 deletions(-) create mode 100644 Documentation/sequencer.txt create mode 100644 sequencer.c create mode 100644 sequencer.h create mode 100755 t/7106-reset-sequence.sh create mode 100755 t/t3510-cherry-pick-sequence.sh -- 1.7.4.rc1.7.g2cf08.dirty -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html