Hi, Nothing new has been introduced; a couple of minor changes have been made since last time (rewrite "config: Introduce functions to write non-standard file" and remove "Please, " in hint: messages). I will hencefourth refer to this series as "sequencer-stable" -- I've started building post midterm work* on top of this. If something critical comes up, I can always fixup this series, rebase and quickly continue my work. While Junio and others are not entirely happy with "revert: Remove sequencer state when no commits are pending", and there is still some confusion about how '--abort' will work in the future, I think we have discussed these issues sufficiently. * I haven't made anything public yet, because it's still in its infancy stages; I'll hopefully have something to show by the end of the week. Thanks for reading. -- Ram Ramkumar Ramachandra (18): advice: Introduce error_resolve_conflict config: Introduce functions to write non-standard file revert: Simplify and inline add_message_to_msg revert: Don't check lone argument in get_encoding revert: Rename no_replay to record_origin revert: Propogate errors upwards from do_pick_commit revert: Eliminate global "commit" variable revert: Introduce struct to keep command-line options revert: Separate cmdline parsing from functional code revert: Don't create invalid replay_opts in parse_args revert: Save data for continuing after conflict resolution revert: Save command-line options for continuing operation revert: Make pick_commits functionally act on a commit list revert: Introduce --reset to remove sequencer state reset: Make reset remove the sequencer state revert: Remove sequencer state when no commits are pending revert: Don't implictly stomp pending sequencer operation revert: Introduce --continue to continue the operation Documentation/git-cherry-pick.txt | 6 + Documentation/git-revert.txt | 6 + Documentation/sequencer.txt | 9 + Makefile | 2 + advice.c | 31 ++- advice.h | 3 +- branch.c | 2 + builtin/revert.c | 743 +++++++++++++++++++++++++++++-------- cache.h | 2 + config.c | 36 ++- sequencer.c | 19 + sequencer.h | 20 + t/7106-reset-sequence.sh | 43 +++ t/t3510-cherry-pick-sequence.sh | 219 +++++++++++ 14 files changed, 969 insertions(+), 172 deletions(-) create mode 100644 Documentation/sequencer.txt create mode 100644 sequencer.c create mode 100644 sequencer.h create mode 100755 t/7106-reset-sequence.sh create mode 100755 t/t3510-cherry-pick-sequence.sh -- 1.7.4.rc1.7.g2cf08.dirty -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html