Hi again, Jonathan Nieder writes: > Ramkumar Ramachandra wrote: > >> It is imperative to note that these two files alone are not enough to >> implement "--continue"; we will also need to persist the options that >> were specified on the command-line, and this is done later in the >> series. > > I think you could remove the phrase "It is imperative to note that" > and this would say the same thing. :) > > By the way, those two files are enough to implement --continue in some > sense, no? One implementation of --continue would forget options > passed on the first run and require the user to specify them again; it > would just be less useful. The reminder that "head" and "todo" are > not the only files in the .git/sequencer dir is useful, though; thanks > for it. New commit message: revert: Save data for continuing after conflict resolution Ever since v1.7.2-rc1~4^2~7 (revert: allow cherry-picking more than one commit, 2010-06-02), a single invocation of "git cherry-pick" or "git revert" can perform picks of several individual commits. To implement features like "--continue" to continue the whole operation, we will need to store some information about the state and the plan at the beginning. Introduce a ".git/sequencer/head" file to store this state, and ".git/sequencer/todo" file to store the plan. The head file contains the SHA-1 of the HEAD before the start of the operation, and the todo file contains an instruction sheet whose format is inspired by the format of the "rebase -i" instruction sheet. As a result, a typical todo file looks like: pick 8537f0e submodule add: test failure when url is not configured pick 4d68932 submodule add: allow relative repository path pick f22a17e submodule add: clean up duplicated code pick 59a5775 make copy_ref globally available Since SHA-1 hex is abbreviated using an find_unique_abbrev(), it is unambiguous. This does not guarantee that there will be no ambiguity when more objects are added to the repository. That these two files alone are not enough to implement a "--continue" that remembers the command-line options specified; later patches in the series save them too. These new files are unrelated to the existing .git/CHERRY_PICK_HEAD, which will still be useful while committing after a conflict resolution. >> --- a/builtin/revert.c >> +++ b/builtin/revert.c > [...] >> +static void format_todo(struct strbuf *buf, struct commit_list *todo_list, >> + struct replay_opts *opts) >> +{ >> + struct commit_list *cur = NULL; >> + struct commit_message msg = { NULL, NULL, NULL, NULL, NULL }; >> + const char *sha1_abbrev = NULL; >> + const char *action; >> + >> + action = (opts->action == REVERT ? "revert" : "pick"); >> + for (cur = todo_list; cur; cur = cur->next) { >> + sha1_abbrev = find_unique_abbrev(cur->item->object.sha1, DEFAULT_ABBREV); >> + if (get_message(cur->item, &msg)) >> + die(_("Cannot get commit message for %s"), sha1_abbrev); >> + strbuf_addf(buf, "%s %s %s\n", action, sha1_abbrev, msg.subject); > > This die() seems odd in the context of a series that starts by > converting various die() calls to "return error()". Fixed. I made format_todo return an int now. >> +static struct commit *parse_insn_line(char *start, struct replay_opts *opts) >> +{ >> + unsigned char commit_sha1[20]; >> + char sha1_abbrev[40]; >> + struct commit *commit; >> + enum replay_action action; >> + int insn_len = 0; >> + char *p; >> + >> + p = start; >> + if (!(p = strchr(p, ' '))) >> + return NULL; > > Style: it is much, much clearer to write > > p = strchr(start, ' '); > if (!p) > return NULL; > > In the git codebase, assignments in "if" conditionals are very rare, so > code like the above sticks out. > >> + insn_len = p - start; >> + if (!(p = strchr(p + 1, ' '))) >> + return NULL; >> + p += 1; > > Likewise. This could say: > > insn_len = p - start; > p = strchr(p + 1, ' '); > if (!p) > return NULL; > p++; Right, got it. Fixed. >> + if (!strncmp(start, "pick", insn_len)) >> + action = CHERRY_PICK; >> + else if (!strncmp(start, "revert", insn_len)) >> + action = REVERT; > > This code means that "p", "pi", and "pic" are accepted as > abbreviations for "pick". Maybe a comment would help to clarify > that. Are we okay with reserving these names, so "r" in a todo > file means to "revert" and not to "reword" like it does in a > rebase -i todo list? That was the original intent, but I clearly hadn't thought about it hard enough. Changed this to accept only full words. >> + /* >> + * Verify that the action matches up with the one in >> + * opts; we don't support arbitrary instructions >> + */ >> + if (action != opts->action) >> + return NULL; > > If I try "git cherry-pick foo..bar" and then "git revert --continue", > what error message will I get? fatal: Malformed instruction sheet: .git/sequencer/todo Technically speaking, this is correct. However, this may not be ideal from an end-user's perspective. Anyway, this is going to change soon -- do you think this is worth correcting here and now? >> +static void read_populate_todo(struct commit_list **todo_list, >> + struct replay_opts *opts) >> +{ > [...] >> + for (p = buf.buf; *p; p = strchr(p, '\n') + 1) { >> + if (!(commit = parse_insn_line(p, opts))) >> + goto error; >> + new = xmalloc(sizeof(struct commit_list)); >> + new->item = commit; >> + *next = new; >> + next = &new->next; > > commit_list_append()? Ugh. Fixed. >> +static void create_seq_dir(void) >> +{ >> + if (file_exists(git_path(SEQ_DIR))) { >> + if (!is_directory(git_path(SEQ_DIR)) && remove_path(git_path(SEQ_DIR)) < 0) >> + die(_("Could not remove %s"), git_path(SEQ_DIR)); >> + } else if (mkdir(git_path(SEQ_DIR), 0777) < 0) >> + die_errno(_("Could not create sequencer directory '%s'."), git_path(SEQ_DIR)); >> +} > > As mentioned in [1], a local would make this more readable. And it's > not clear to me why one would want to delete a .git/sequencer file > that the user carefully placed there (I don't think git itself ever > writes such a thing). Okay, removed that hunk. >> +static void save_head(const char *head) >> +{ >> + static struct lock_file head_lock; >> + struct strbuf buf = STRBUF_INIT; >> + int fd; >> + >> + fd = hold_lock_file_for_update(&head_lock, git_path(SEQ_HEAD_FILE), LOCK_DIE_ON_ERROR); >> + strbuf_addf(&buf, "%s\n", head); >> + if (write_in_full(fd, buf.buf, buf.len) < 0) >> + die_errno(_("Could not write to %s."), git_path(SEQ_HEAD_FILE)); >> + if (commit_lock_file(&head_lock) < 0) >> + die(_("Error wrapping up %s"), git_path(SEQ_HEAD_FILE)); >> +} > > A local would be helpful here, too. > >> +static void save_todo(struct commit_list *todo_list, struct replay_opts *opts) >> +{ >> + static struct lock_file todo_lock; >> + struct strbuf buf = STRBUF_INIT; >> + int fd; >> + >> + fd = hold_lock_file_for_update(&todo_lock, git_path(SEQ_TODO_FILE), LOCK_DIE_ON_ERROR); >> + format_todo(&buf, todo_list, opts); >> + if (write_in_full(fd, buf.buf, buf.len) < 0) { >> + strbuf_release(&buf); >> + die_errno(_("Could not write to %s."), git_path(SEQ_TODO_FILE)); >> + } >> + if (commit_lock_file(&todo_lock) < 0) { >> + strbuf_release(&buf); >> + die(_("Error wrapping up %s"), git_path(SEQ_TODO_FILE)); >> + } >> + strbuf_release(&buf); >> +} > > Likewise here. As mentioned before, git_path() clobbers errno, so the > above is likely to print a wrong error message on some systems (e.g., > "fatal: Cannot write to .git/sequencer/todo: Success"). Fixed these. Thanks. >> +static int pick_commits(struct replay_opts *opts) >> +{ >> + struct commit_list *todo_list = NULL; >> + unsigned char sha1[20]; >> + struct commit_list *cur; >> + int res; >> >> setenv(GIT_REFLOG_ACTION, me, 0); >> if (opts->allow_ff) >> @@ -580,14 +764,24 @@ static int pick_commits(struct replay_opts *opts) >> opts->record_origin || opts->edit)); >> read_and_refresh_cache(me, opts); >> >> - prepare_revs(&revs, opts); >> + walk_revs_populate_todo(&todo_list, opts); >> + create_seq_dir(); >> + if (!get_sha1("HEAD", sha1)) >> + save_head(sha1_to_hex(sha1)); > > What happens if the .git/sequencer dir already exists (e.g., we were > in the middle of a multiple-cherry-pick)? What happens if I try to > cherry-pick onto an unborn branch, or get_sha1() fails for some other > reason? Oops. I lost this somewhere along the way -- fixed now. Thanks :) -- Ram -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html