Jeff King <peff@xxxxxxxx> writes: > Yeah, they probably should both be unsigned, and the sorted flag should > be a bit-field (not that it saves any space here, but it makes its purpose > more clear). > > Junio, do you mind squashing this into patch 2/3? I actually do ;-) If you grep for ALLOC_GROW and look at the structures they touch, nr/alloc pairs that are integers are the majority in our codebase, and I do not see much bikeshedding value in adding more unsigned ones to the mix. > diff --git a/sha1-array.h b/sha1-array.h > index 15d3b6b..b602303 100644 > --- a/sha1-array.h > +++ b/sha1-array.h > @@ -3,9 +3,9 @@ > > struct sha1_array { > unsigned char (*sha1)[20]; > - int nr; > - int alloc; > - int sorted; > + unsigned nr; > + unsigned alloc; > + unsigned sorted:1; > }; > > #define SHA1_ARRAY_INIT { NULL, 0, 0, 0 } > > -Peff -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html