On Thu, Feb 17, 2011 at 08:44:42AM +0100, Michael J Gruber wrote: > --- a/builtin/patch-id.c > +++ b/builtin/patch-id.c > @@ -73,6 +73,8 @@ int get_one_patchid(unsigned char *next_sha1, git_SHA_CTX *ctx) > p += 7; > else if (!memcmp(line, "From ", 5)) > p += 5; > + else if (!memcmp(line, "\\ ", 2) && strlen(line)>=12) > + continue; Wow, that's pretty obscure. I wonder if the test should be factored out into line_is_no_newline_at_end_of_file() (or surely there is some more sensible name), and used by both apply and patch-id. Along with a nice comment (which I see apply already has) describing what in the world the magic number 12 means. -Peff -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html