This patch series allows for `git merge` to default to the upstream branch of the current branch. Notes/Complications: - I'm not sure whether the option should be merge.defaultUpstream or merge.defaultToUpstream - Should [remotes] be changed to [branches]? I felt like it was a completely different change and didn't belong in the patch series. - I left one of the ifs with unnecessary braces for clarity because of a nested if-else: is this the preferred style? Jared Hance (3): Add setup_merge_commit function to merge/builtin.c. Add function per_branch_config. Add support for merging from upstream by default. Documentation/config.txt | 6 +++ builtin/merge.c | 87 ++++++++++++++++++++++++++++++++------------- 2 files changed, 68 insertions(+), 25 deletions(-) -- 1.7.4 -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html