On Wed, Jan 19, 2011 at 03:11:12PM +0100, Libor Pechacek wrote: > Sanity-ckeck config variable names when adding and retrieving them. > > As a side effect code duplication between git_config_set_multivar and get_value > (in builtin/config.c) was removed and the common functionality was placed in > git_config_parse_key. I think this is a good goal, but a few nits: > +/* Auxiliary function to sanity-check and split the key into the section > + * identifier and variable name. > + * > + * Returns 0 on success, 1 when there is an invalid character in the key and 2 > + * if there is no section name in the key. Please switch these to -1 and -2, as we generally use negative integers to indicate errors in library-ish function. I know you were just copying git_config_set_multivar's error codes, but it is designed to return straight to exit(), which makes it an exception. Other than that, the code looks OK to me. However, it does cause t1300.85 to fail. The problem is that the test is using these bogus names to check that "git -c" works. While it does technically work now to say "git -c foo=bar config foo" (which your patch breaks), I don't think that is a useful behavior in the real world, since no actual config options exist without a section name. So yes, you can "git -c" a non-sectioned variable, but why would you want to? So I think it probably makes sense to squash this in: diff --git a/t/t1300-repo-config.sh b/t/t1300-repo-config.sh index d0e5546..3e79c37 100755 --- a/t/t1300-repo-config.sh +++ b/t/t1300-repo-config.sh @@ -876,11 +876,10 @@ test_expect_success 'check split_cmdline return' " " test_expect_success 'git -c "key=value" support' ' - test "z$(git -c name=value config name)" = zvalue && test "z$(git -c core.name=value config core.name)" = zvalue && - test "z$(git -c CamelCase=value config camelcase)" = zvalue && - test "z$(git -c flag config --bool flag)" = ztrue && - test_must_fail git -c core.name=value config name + test "z$(git -c foo.CamelCase=value config foo.camelcase)" = zvalue && + test "z$(git -c foo.flag config --bool foo.flag)" = ztrue && + test_must_fail git -c name=value config core.name ' test_done and a note to the commit message like: This breaks a test in t1300 which used invalid section-less keys in the tests for "git -c". However, allowing such names there was useless, since there was no way to set them via config file, and no part of git actually tried to use section-less keys. This patch updates the test to use more realistic examples. -Peff -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html