Changes from v4: * better API documentation (was previously lacking or plain obsolete) * added one more wrapper (used by yet-to-be-resent bulk-* series Notes on current API: * The macro names are a bit heavy-weight. Better ideas welcome. * This API is very verbose, and I'm not happy with that aspect. It could be made less so, eg. causing insert wrappers to auto-declare the required generic insert func, and causing the latter auto-declare the required generic search func. That would cause duplication of the generic search func in many cases. The duplication problem would not be an issue if we add an automatic call to declare_gen_sorted_insert() in declare_sorted_array_insert_*, but we would loose the symetry with the search API. Adding "simple" API variants that would call all the necessary stuff would help code readability, but adding yet more entry points seems a dubious approach. Or is that just the "use cpp for templating" just inadequate here ? * could gain a dealloc API, to minimize the explicit use of the _nr and _alloc vars The following binary-search occurences were not converted: * read-cache.c::index_name_pos has widely-used API with 2 low-coupled cmp/init params: sorted-array could be generalized at the cost of using stdarg, but is it worth it ? * pack-revindex.c::find_pack_revindex is a bit special and needs more thought * cache-tree.c::subtree_pos and sha1_file::find_pack_entry_one too * sha1_lookup.c stuff probably too special -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html