Bo Yang <struggleyb.nku@xxxxxxxxx> writes: > The function rewrite_one is used to rewrite a single > parent of the current commit, and is used by rewrite_parents > to rewrite all the parents. > This commit decouple the dependence between them, make > rewrite_one as a callback function and be passed to > rewrite_parents. Make rewrite_parents public to other > part of git. > We will use this function in line.c. Sorry, but -ECANTREALLYPARSE. This particular refactoring is probably harmless, but we would need to see how it is used to convince ourselves it is a good change. > @@ -1920,7 +1914,8 @@ static enum rewrite_result rewrite_one(struct rev_info *revs, struct commit **pp > } > } > > -static int rewrite_parents(struct rev_info *revs, struct commit *commit) > +int rewrite_parents(struct rev_info *revs, struct commit *commit, > + rewrite_parent rewrite_one) > { > struct commit_list **pp = &commit->parents; > while (*pp) { > @@ -1993,7 +1988,7 @@ enum commit_action simplify_commit(struct rev_info *revs, struct commit *commit) > if (action == commit_show && > !revs->show_all && > revs->prune && revs->dense && want_ancestry(revs)) { > - if (rewrite_parents(revs, commit) < 0) > + if (rewrite_parents(revs, commit, rewrite_one) < 0) > return commit_error; > } > return action; It would probably make sense to rename this "rewrite_one" (local function pointer variable) not to collide with the "rewrite_one" (static function) for readability. > diff --git a/revision.h b/revision.h > index 433da9a..9b8e3d9 100644 > --- a/revision.h > +++ b/revision.h > @@ -200,4 +200,14 @@ enum commit_action { > extern enum commit_action get_commit_action(struct rev_info *revs, struct commit *commit); > extern enum commit_action simplify_commit(struct rev_info *revs, struct commit *commit); > > +enum rewrite_result { > + rewrite_one_ok, > + rewrite_one_noparents, > + rewrite_one_error > +}; > + > +typedef enum rewrite_result (*rewrite_parent)(struct rev_info *revs, struct commit **pp); Yikes; at least name the type rewrite_parent_fn or something for readability. > +extern int rewrite_parents(struct rev_info *revs, struct commit *commit, > + rewrite_parent rewrite_one); > #endif > -- > 1.7.0.2.273.gc2413.dirty -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html