Re: [PATCH v3 02/13] parse-options: add two helper functions

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Bo Yang <struggleyb.nku@xxxxxxxxx> writes:

> +int parse_options_next(struct parse_opt_ctx_t *ctx, int retain)

I think the latter is usually called "keep".

> +{
> +	if (ctx->argc <= 0)
> +		return -1;
> +
> +	if (retain == 1)

Should this really check for "1", or would

	if (keep)

be more conventional?
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]