Jeff King <peff@xxxxxxxx> writes: > On Mon, Mar 15, 2010 at 02:40:03PM -0700, Lars Damerow wrote: > >> + if (getenv("GIT_ONE_FILESYSTEM") != NULL) { > > Should this really trigger for GIT_ONE_FILESYSTEM=0? We already have > git_env_bool, which will handle 0/1, true/false, etc. Probably you > should use it here. > > I am not a big fan of the environment variable name, either, but I don't > have another good suggestion. It is closely related to > GIT_CEILING_DIRECTORIES (in fact, you could probably solve the same > problem with GIT_CEILING_DIRECTORIES, but I think your solution is much > nicer in that it lets the user get away with being less verbose). Yeah, that, or toplevel global option --one-file-system given to "git", but I think that is probably too cumbersome. How inefficient is it to repeatedly call getenv() in a loop, by the way? I think the patch would become easier to read if env_bool() is called once at the beginning to set a local variable, and not even do the initial stat() for "." if this feature is not asked for. -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html