Thomas Rast <trast@xxxxxxxxxxxxxxx> writes: > Teach git-format-patch a new option --comment-notes (with config > format.commentNotes) which takes a notes ref argument. These notes > are then added to the patch email between the --- separator and the > diffstat/diff. Hmmm, why do I find this an ugly hack? You already have a nice "format_display_notes()" infrastructure to allow users to get notes from arbitrary notes namespaces, yet this limits the user to a single notes namespace. What was the infrastructure built for if not used in places like this uniformly? If the answer is "because notes.displayref is a configuration and it is cumbersome to change every time", then I don't have a sympathy ;-) as that is exactly why I said config without command line override is a bad thing. > diff --git a/Documentation/git-format-patch.txt b/Documentation/git-format-patch.txt > index 9674f9d..afe7e41 100644 > --- a/Documentation/git-format-patch.txt > +++ b/Documentation/git-format-patch.txt > @@ -198,6 +198,16 @@ you can use `--suffix=-patch` to get `0001-description-of-my-change-patch`. > range are always formatted as creation patches, independently > of this flag. > > +--comment-notes=<ref>:: > + Use the notes from <ref> to fill the comment section of the > + email, i.e., the part between the `\---` separator and the > + patch. See linkgit:git-notes[1]. > ++ > +Warning: the code currently does not guard against a line in the notes > +that starts with `diff`, which will be treated as the start of the > +patch by 'git-am'. It is customary to indent the material after --- by one place (or more) so it probably is a good idea to do that for notes as well, if we are going to put it after the three dash lines. Notice that diffstat output is already indented that way ;-). > @@ -457,6 +458,7 @@ int log_tree_diff_flush(struct rev_info *opt) > } > > if (opt->loginfo && !opt->no_commit_id) { > + const unsigned char *sha1 = opt->loginfo->commit->object.sha1; > /* When showing a verbose header (i.e. log message), > * and not in --pretty=oneline format, we would want > * an extra newline between the end of log and the > @@ -467,10 +469,20 @@ int log_tree_diff_flush(struct rev_info *opt) > opt->verbose_header && > opt->commit_format != CMIT_FMT_ONELINE) { > int pch = DIFF_FORMAT_DIFFSTAT | DIFF_FORMAT_PATCH; > - if ((pch & opt->diffopt.output_format) == pch) > + if ((pch & opt->diffopt.output_format) == pch > + || (opt->commit_format == CMIT_FMT_EMAIL > + && opt->show_notes)) This adds a lot of logic to a code that used to be simple "if we have more stuff to add after message, delimit with "---\n"". Perhaps the whole body of the "if" statement ll. 460- should be made into a static helper function with a single callsite that a clever compiler would inline. Also I think you would emit "---" even if the commit in question does not happen to have note with this code. I've attached a "how about doing it this way" weatherbaloon patch to be applied on top of this patch at the end---I didn't bother to indent the notes text nor change it to use format_display_notes(), but hopefully you will agree the code structure would be easier to follow this way. > diff --git a/pretty.c b/pretty.c > index 6ba3da8..10d7812 100644 > --- a/pretty.c > +++ b/pretty.c > @@ -1095,7 +1095,7 @@ void pretty_print_commit(enum cmit_fmt fmt, const struct commit *commit, > if (fmt == CMIT_FMT_EMAIL && sb->len <= beginning_of_body) > strbuf_addch(sb, '\n'); > > - if (context->show_notes) > + if (context->show_notes && fmt != CMIT_FMT_EMAIL) > format_display_notes(commit->object.sha1, sb, encoding, > NOTES_SHOW_HEADER | NOTES_INDENT); This is a good fix to prevent notes from getting injected above the separator line, regardless of your series, I think. log-tree.c | 71 +++++++++++++++++++++++++++++++++++++++-------------------- 1 files changed, 47 insertions(+), 24 deletions(-) diff --git a/log-tree.c b/log-tree.c index 9baf306..af65d33 100644 --- a/log-tree.c +++ b/log-tree.c @@ -445,6 +445,52 @@ void show_log(struct rev_info *opt) strbuf_release(&msgbuf); } +static void log_tree_after_message(struct rev_info *opt) +{ + const int pch = (DIFF_FORMAT_DIFFSTAT|DIFF_FORMAT_PATCH); + struct strbuf sb = STRBUF_INIT; + + /* + * When showing a verbose header (i.e. log message), + * and not in --pretty=oneline format, we would want + * an extra newline between the end of log and the + * output for readability. + */ + if (! ((opt->diffopt.output_format & ~DIFF_FORMAT_NO_OUTPUT) && + opt->verbose_header && + opt->commit_format != CMIT_FMT_ONELINE) ) + return; + + /* + * Prepare notes if any... + */ + if (opt->commit_format == CMIT_FMT_EMAIL && opt->show_notes) + format_note(NULL, opt->loginfo->commit->object.sha1, + &sb, NULL, 0); + + /* + * Will we have something other than the message itself? If + * so we would need three-dashes. + */ + if (((pch & opt->diffopt.output_format) == pch) || sb.len) + printf("---"); + + /* + * Then the promised newline... + */ + putchar('\n'); + + /* + * And finally the notes... + */ + if (sb.len) { + putchar('\n'); + fwrite(sb.buf, 1, sb.len, stdout); + strbuf_release(&sb); + putchar('\n'); + } +} + int log_tree_diff_flush(struct rev_info *opt) { diffcore_std(&opt->diffopt); @@ -458,31 +504,8 @@ int log_tree_diff_flush(struct rev_info *opt) } if (opt->loginfo && !opt->no_commit_id) { - const unsigned char *sha1 = opt->loginfo->commit->object.sha1; - /* When showing a verbose header (i.e. log message), - * and not in --pretty=oneline format, we would want - * an extra newline between the end of log and the - * output for readability. - */ show_log(opt); - if ((opt->diffopt.output_format & ~DIFF_FORMAT_NO_OUTPUT) && - opt->verbose_header && - opt->commit_format != CMIT_FMT_ONELINE) { - int pch = DIFF_FORMAT_DIFFSTAT | DIFF_FORMAT_PATCH; - if ((pch & opt->diffopt.output_format) == pch - || (opt->commit_format == CMIT_FMT_EMAIL - && opt->show_notes)) - printf("---"); - putchar('\n'); - } - if (opt->commit_format == CMIT_FMT_EMAIL && opt->show_notes) { - struct strbuf sb = STRBUF_INIT; - putchar('\n'); - format_note(NULL, sha1, &sb, NULL, 0); - fwrite(sb.buf, 1, sb.len, stdout); - strbuf_release(&sb); - putchar('\n'); - } + log_tree_after_message(opt); } diff_flush(&opt->diffopt); return 1; -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html