Michael Lukashov <michael.lukashov@xxxxxxxxx> writes: > The following functions: > > git_tcp_connect_sock (IPV6 version) > git_tcp_connect_sock (no IPV6 version), > git_proxy_connect > > have common block of code. Move it to a new function 'get_host_and_port' > > Signed-off-by: Michael Lukashov <michael.lukashov@xxxxxxxxx> > @@ -170,30 +192,14 @@ static const char *ai_name(const struct addrinfo *ai) > static int git_tcp_connect_sock(char *host, int flags) > ... > - if (colon) { > - *colon = 0; > - port = colon + 1; > - if (!*port) > - port = "<none>"; > - } > + get_host_and_port(&host, &port); > + if (!*port) > + *port = "<none>"; Is this version any different from v2? I expected that at least this one would have been fixed from the older version. -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html