David Aguilar schrieb: > - $GIT_DIFFTOOL_EXTCMD "$LOCAL" "$REMOTE" > + (eval $GIT_DIFFTOOL_EXTCMD "\"$LOCAL\"" "\"$REMOTE\"") The new code is broken if $LOCAL or $REMOTE can contain double-quotes. How about this alternative: eval $GIT_DIFFTOOL_EXTCMD '"$LOCAL"' '"$REMOTE"' which I find more readable as well. What's the reason for the sub-shell? Do you want to protect from shell code in $GIT_DIFFTOOL_EXTCMD that modifies difftool's variables? -- Hannes -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html