Hi, On Wed, 4 Nov 2009, Andrzej K. Haczewski wrote: > diff --git a/builtin-pack-objects.c b/builtin-pack-objects.c > index 02f9246..c96d293 100644 > --- a/builtin-pack-objects.c > +++ b/builtin-pack-objects.c > @@ -2327,6 +2327,18 @@ int cmd_pack_objects(int argc, const char **argv, const char *prefix) > #ifdef THREADED_DELTA_SEARCH > if (!delta_search_threads) /* --threads=0 means autodetect */ > delta_search_threads = online_cpus(); > + > +#ifdef _WIN32 This flies in the face of our endeavors to enhance readability by reducing the number of #ifdef's, and at least guarding the #ifdef'ed parts behind meaningful names rather than platform specifiers. See for example THREADED_DELTA_SEARCH: it does not read "HAS_PTHREADS" or some such. Ciao, Dscho -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html