Misc. cleanups of the Config class (aka the base class for RepositoryConfig) to make the code easier to follow. I came about this series because I started to do improvements to the Config class to better support submodule introspection from a bare repository... and I realized this code was a mess. This series (or at least the first patch of it) applies on top of my prior 11 patch series for alternate object database improvements. Shawn O. Pearce (12): Use NB.readFully(File) to slurp complete file contents Correct name of fileRead member of Config class Add setLong to Config Fix Config setInt(..., 0) to store "0" not "0 g" Rename Config.unsetString to just unset() Remove pointless null assignments in Config Clarify section and subsection values in Config code Don't subclass PrintWriter when writing the Config Use a Java 5 style iteration over the Config entries list Match config subsection names using case sensitive search Cleanup Config's MAGIC_EMPTY_VALUE to be more safe Remove unreferenced REMOTE_SECTION from RepositoryConfig .../src/org/spearce/jgit/lib/Config.java | 196 +++++++++++--------- .../src/org/spearce/jgit/lib/FileBasedConfig.java | 7 +- .../src/org/spearce/jgit/lib/RefDatabase.java | 15 +- .../src/org/spearce/jgit/lib/ReflogReader.java | 32 +--- .../src/org/spearce/jgit/lib/RepositoryCache.java | 20 +- .../src/org/spearce/jgit/lib/RepositoryConfig.java | 4 - .../org/spearce/jgit/lib/UnpackedObjectLoader.java | 15 +-- .../org/spearce/jgit/transport/RemoteConfig.java | 2 +- org.spearce.jgit/src/org/spearce/jgit/util/NB.java | 52 +++++ 9 files changed, 195 insertions(+), 148 deletions(-) -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html