On Thu, May 07, 2009 at 11:47:03AM -0400, Don Slutz wrote: > Here is a change back to using spaces. It also includes a change > to test for the code working. Squash on top. Maybe it is just me, but I think test_expect_success SYMLINKS,SANITY 'some description' ' the actual test ' is more readable than the space (since it keeps the number of single quoted chunks on the line down). Which should be as simple as: > -# prerequisites can be concatenated with '+' > test_have_prereq () { > - save_IFS=$IFS > - IFS=+ > - set -- $* > - IFS=$save_IFS > - for prerequisite > + for prerequisite in $(echo $*) > do > case $satisfied in > *" $prerequisite "*) +for prerequisite in $(echo "$1" | tr , ' ') Just my bikeshedding two cents, -Peff -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html