Re: two small patches

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Henrik Akesson wrote:
> Two patches attached. I've made the below comments in a more suitable
> ChangeLog format:
>
> [gegl_buffer.diff]
>
> Patch from Henrik Akesson:
> - Extracted duplicated code from pset/pget into a separate function
> gegl_buffer_in_abyss to improve readability of code and maintainability.
> - Renamed pset/pget to gegl_buffer_pixel_set and gegl_buffer_pixel_get
> in order to improve readability of code and to be conformant to gegl
> coding standards.
>

Hi,

Do you think you can split up that patch into two patches? One with the
renames and one with the new utility function. It also added g_debug()
statements that were commented away, please remove those. Thanks!

> [gegl_utils.diff]
>
> Patch from Henrik Akesson that adds a gegl_rectangle_as string
> function for retreiving a rectangle as a debug string. Log statements
> has been changed to use this said function as well as using GEGL_NOTE
> (see gegl-debug.h).

That leaks memory because the data returned from g_string_free() needs
to be freed if FALSE is passed to the free_segment parameter (you pass
NULL (!)). Otherwise it is a nice change. Could you address the memory
leaks please?

BR,
Martin
_______________________________________________
Gegl-developer mailing list
Gegl-developer@xxxxxxxxxxxxxxxxxxxxxx
https://lists.XCF.Berkeley.EDU/mailman/listinfo/gegl-developer

[Index of Archives]     [Yosemite News]     [Yosemite Photos]     [gtk]     [GIMP Users]     [KDE]     [Gimp's Home]     [Gimp on Windows]     [Steve's Art]

  Powered by Linux