Nicolas Robidoux wrote: > Hello gegl developers: > > OPTION 1: > > Keep yafr-smooth and yafr-nohalo. The bugzilla would get rid of the > current yafr and replace them with two new methods: smooth---which is > like the current yafr, just about 5% faster---and nohalo, which is > even faster. (I'm keeping the "yafr" out of it because it means > nothing to users.) > > OPTION 2: > > Merging the two into a single yafr. > > Then, I need to know how to let the user pass a parameter---most > intuitively called "halo"---to the method when it is called (a bit > like one passes an angle to the rotate utility). > > Q1: Any preference between the two options? > > Q2: If Option 2 is preferred, can someone direct me toward what I need > to know to be able to get the halo parameter from the user (not at > compile time, in "real" time)? > Hi A1: If having two separate ops would lead to a lot of code duplication then it is better to parameterize a single op with what method to use. A2: The halo parameter will be a GObject property set up in _class_init() and then settable through _set_property() and gettable through _get_property() as usual. As far as I know GEGL makes use of introspection to build up UIs for op properties, so just adding the property should be enough in order to allow it to be changed in the gegl binary that comes with GEGL. You can of course wrap any UI around it; it's just a normal GObject property settable by anything. - Martin _______________________________________________ Gegl-developer mailing list Gegl-developer@xxxxxxxxxxxxxxxxxxxxxx https://lists.XCF.Berkeley.EDU/mailman/listinfo/gegl-developer