On 12/4/06, Øyvind Kolås <pippin@xxxxxxxx> wrote: > > 2. The term "bounding box" is clearer than "defined region". > > *gegl_node_get_bounding_box > > The names of the concept internally, and a decision externally > might be propagated to the inside as well. Another option might be > gegl_node_get_bounds , or with a naming choice more similar to the > ones used by cairo, gegl_node_get_extents. I've renamed this one to gegl_node_get_bounding_box for now, I think gegl_node_get_dirty_rect should be renamed to be more similar to gegl_node_get_bounding_box. Perhaps: gegl_node_get_bounding_box () gegl_node_get_dirty_bounding_box (); gegl_node_clear_dirty (); or gegl_node_get_bounding_box () gegl_node_get_uncomputed_bounding_box (); gegl_node_clear_uncomputed (); Looking at this I realize that there should probably be some changes to how this dirt is handled, a projection should keep track of this itself, and instead of accumulating the dirt in the nodes, it should ideally be propagated to the projections. Doing so efficiently might require some pondering though. /Øyvind L. -- «The future is already here. It's just not very evenly distributed» -- William Gibson http://pippin.gimp.org/ http://ffii.org/ _______________________________________________ Gegl-developer mailing list Gegl-developer@xxxxxxxxxxxxxxxxxxxxxx https://lists.XCF.Berkeley.EDU/mailman/listinfo/gegl-developer