Re: [PATCH] generic: suggest fs specific fix only if the tested filesystem matches

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]



On Thu, Feb 06, 2025 at 06:11:11AM -0800, Christoph Hellwig wrote:
> On Thu, Feb 06, 2025 at 01:05:06PM +0000, fdmanana@xxxxxxxxxx wrote:
> > +if [ "$FSTYP" = "xfs" ]; then
> > +	_fixed_by_kernel_commit 68415b349f3f \
> > +		"xfs: Fix the owner setting issue for rmap query in xfs fsmap"
> > +	_fixed_by_kernel_commit ca6448aed4f1 \
> > +		"xfs: Fix missing interval for missing_owner in xfs fsmap"
> > +fi
> 
> How about you add a new helper instead of the boilerplate, something
> like
> 
> _fixed_by_fs_kernel_commit xfs 68415b349f3f \
> 	"xfs: Fix the owner setting issue for rmap query in xfs fsmap"

While we're at it, we should move these _fixed_by* functions to a
separate file to declutter common/rc?

And maybe add a few more dumb wrappers like

_fixed_by_xfsprogs_commit()
{
	test "$FSTYP" = "xfs" && \
		__fixed_by_git_commit xfsprogs "$@"
}

to replace the opencoded versions?

--D

> ?
> 




[Index of Archives]     [Linux Filesystems Development]     [Linux NFS]     [Linux NILFS]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux