Re: [PATCH] debug: add tests for debugging testing setup

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]



Oops, should have put all my replies this message. Please see my
reply to Darrick's email as well.

On Thu, Feb 09, 2023 at 01:53:02PM +0800, Zorro Lang wrote:
> On Wed, Feb 08, 2023 at 06:47:30PM -0800, Darrick J. Wong wrote:
> > On Wed, Feb 08, 2023 at 05:31:43PM -0800, Leah Rumancik wrote:
> > > Many people have developed infrastructure around xfstests. In order to
> > > test a setup, it would be helpful to have dummy tests that have
> > > consistent test outcomes. Add a new test folder with the following
> > > debugging tests:
> > 
> > Ooh, we've been needing selftests for a while, thanks!
> > 
> > > debug/001 pass
> > > debug/002 fail
> > > debug/003 skip
> > > debug/004 crash
> > > debug/005 hang
> > > 
> > > Signed-off-by: Leah Rumancik <leah.rumancik@xxxxxxxxx>
> > > ---
> > > 
> > > diff --git a/doc/group-names.txt b/doc/group-names.txt
> > > index 6cc9af78..212da7e7 100644
> > > --- a/doc/group-names.txt
> > > +++ b/doc/group-names.txt
> > > @@ -39,6 +39,7 @@ dangerous_scrub		fuzzers to evaluate xfs_scrub checking
> > >  data			data loss checkers
> > >  dax			direct access mode for persistent memory files
> > >  db			xfs_db functional tests
> > > +debug			tests with fixed results, used to validate testing setup
> > 
> > Bikeshed: Can we make the tag 'selftests' since debugging could refer to
> > just about anything in the kernel/userspace/otherstuff stacks?
> > 
> > Also a dangerous_selftests for tests that will crash or hang the test
> > appliances.  I'd really like to run this every time I start up fstests,
> > albeit without the dangerous ones. :)
> 
> I agree with this. When I saw *debug*, I thought it's about some kernel/fs
> debuging test, or it need kernel debug option. So *selftest* might be a better
> name, or if someone has better idea :)
> 
> With group name changing, I think better to change tests/debug/ directory to
> tests/selftests/.

Will do!

> > > diff --git a/tests/debug/Makefile b/tests/debug/Makefile
> > > new file mode 100644
> > > index 00000000..84556199
> > > --- /dev/null
> > > +++ b/tests/debug/Makefile
> > > @@ -0,0 +1,24 @@
> > > +#
> > > +# Copyright (c) 2003-2005 Silicon Graphics, Inc.  All Rights Reserved.
> 
> Do you need to change this ^^ ?
Ah yes, thanks!

- Leah

> 
> Thanks,
> Zorro
> 
> > > +#
> > > +
> > > +TOPDIR = ../..
> > > +include $(TOPDIR)/include/builddefs
> > > +include $(TOPDIR)/include/buildgrouplist
> > > +
> > > +DEBUG_DIR = debug
> > > +TARGET_DIR = $(PKG_LIB_DIR)/$(TESTS_DIR)/$(DEBUG_DIR)
> > > +DIRT = group.list
> > > +
> > > +default: $(DIRT)
> > > +
> > > +include $(BUILDRULES)
> > > +
> > > +install:
> > > +	$(INSTALL) -m 755 -d $(TARGET_DIR)
> > > +	$(INSTALL) -m 755 $(TESTS) $(TARGET_DIR)
> > > +	$(INSTALL) -m 644 group.list $(TARGET_DIR)
> > > +	$(INSTALL) -m 644 $(OUTFILES) $(TARGET_DIR)
> > > +
> > > +# Nothing.
> > > +install-dev install-lib:
> > > -- 
> > > 2.39.1.519.gcb327c4b5f-goog
> > > 
> > 
> 



[Index of Archives]     [Linux Filesystems Development]     [Linux NFS]     [Linux NILFS]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux