Re: [PATCH 5/6] src/fssum: Allow single file input

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]



On Sun, May 31, 2020 at 9:29 PM Arvind Raghavan
<raghavan.arvind@xxxxxxxxx> wrote:
>
> On 05/22, Amir Goldstein wrote:
> > On Fri, May 22, 2020 at 4:06 AM Arvind Raghavan
> > <raghavan.arvind@xxxxxxxxx> wrote:
> > >
> > > On 05/21, Amir Goldstein wrote:
> > > > On Thu, May 21, 2020 at 3:10 AM Arvind Raghavan
> > > > <raghavan.arvind@xxxxxxxxx> wrote:
> > > > >
> > > > > Allow regular links and symlinks to be passed as input to fssum.
> > > > >
> > > > > Signed-off-by: Arvind Raghavan <raghavan.arvind@xxxxxxxxx>
> > > > > Signed-off-by: Jayashree Mohan <jaya@xxxxxxxxxxxxx>
> > > > > Signed-off-by: Vijay Chidambaram <vijay@xxxxxxxxxxxxx>
> > > > > ---
> > > > >  src/fssum.c | 35 ++++++++++++++++++++++++++++++++++-
> > > > >  1 file changed, 34 insertions(+), 1 deletion(-)
> > > > >
> > > > > diff --git a/src/fssum.c b/src/fssum.c
> > > > > index ece0f556..2d1624ca 100644
> > > > > --- a/src/fssum.c
> > > > > +++ b/src/fssum.c
> > > > > @@ -29,6 +29,7 @@
> > > > >  #include <inttypes.h>
> > > > >  #include <assert.h>
> > > > >  #include <endian.h>
> > > > > +#include <libgen.h>
> > > > >
> > > > >  #define CS_SIZE 16
> > > > >  #define CHUNKS 128
> > > > > @@ -884,8 +885,40 @@ main(int argc, char *argv[])
> > > > >         if (gen_manifest)
> > > > >                 fprintf(out_fp, "Flags: %s\n", flagstring);
> > > > >
> > > > > +       struct stat64 path_st;
> > > > > +       if (fstat64(fd, &path_st)) {
> > > > > +               perror("fstat");
> > > > > +               exit(-1);
> > > > > +       }
> > > > > +
> > > > >         sum_init(&cs);
> > > > > -       sum(fd, 1, &cs, path, "");
> > > > > +
> > > > > +       if (S_ISDIR(path_st.st_mode)) {
> > > > > +               sum(fd, 1, &cs, path, "");
> > > > > +       } else if (S_ISREG(path_st.st_mode) || S_ISLNK(path_st.st_mode)) {
> > > > > +               // Copy because dirname may modify path
> > > > > +               char* path_copy = alloc(strlen(path));
> > > > > +               strcpy(path_copy, path);
> >
> > If you stay with this code please use strdup().
> >
> > > > > +
> > > > > +               char* dir_path = dirname(path);
> > > > > +               char* name = basename(path_copy);
> > > > > +
> > > > > +               int dirfd = open(dir_path, O_RDONLY);
> > > > > +               if (fd == -1) {
> > > > > +                       fprintf(stderr, "failed to open %s: %s\n", dir_path,
> > > > > +                               strerror(errno));
> > > > > +                       exit(-1);
> > > > > +               }
> > > > > +
> > > > > +               sum_one(dirfd, 1, &cs, dir_path, "", name);
> > > >
> > > > Instead of all of the above, how about just:
> > > >                sum_one(fd, 1, &cs, path, "", "");
> > > >
> > > > From looking at sum_one() code, it seems to me like that will work,
> > > > but I may be missing something.
> > > > It's not that you *want* the name in the checksum, it is not even
> > > > part of the metadata that is being synced with fsync.
> > >
> > > The issue here is that we preserved the code from sum which does
> > > all its opens using openat with the parent directory fd and a
> > > filename. Since we're trying to reuse that code I believe we need
> > > to have this somewhat ugly boilerplate.
> >
> > Ok. But if you stay with this please add a comment about why
> > this is done with a hint for the future how to fix this properly.
> >
> > Or (up to you) you can fix it by calling this helper instead of openat():
> >
> > int open_one(int dirfd, const char *name)
> > {
> >     if (!name || !*name)
> >         return dup(dirfd);
> >     return openat(dirfd, name, 0);
> > }
> >
> > fstatat() can take empty name with AT_EMPTY_PATH flag.
> > readlinkat() should be able to take an empty name, but documentation
> > is not clear whether fd must be O_PATH - need to verify if it works with
> > non O_PATH fd.
>
> I might be doing something wrong but I can't seem to get
> AT_EMPTY_PATH to work with fstatat. I don't see it on the man
> page and when I pass it to fstatat it errors out with invalid
> argument.
>

https://www.man7.org/linux/man-pages/man2/stat.2.html

Says:
       AT_EMPTY_PATH (since Linux 2.6.39)
... This flag is Linux-specific; define _GNU_SOURCE to obtain its definition.

And I see that fssum.c does define _GNU_SOURCE, so not sure what the
problem is.

> In the case that fstatat doesn't support AT_EMPTY_PATH, do you
> see another way to fix the above code?
>

Yes, you can pass path_st to sum_one() you already have it.

But I don't think that you or anyone that cares about xfstests is running
a kernel older than 2.6.39...

Thanks,
Amir.



[Index of Archives]     [Linux Filesystems Development]     [Linux NFS]     [Linux NILFS]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux