Re: another type of broken ~/.fonts.cache-2 file

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Mike FABIAN wrote:
> If I copy .fonts.cache-2.bad to ~/.fonts.cache-2,
> "fc-match sans" seems to loop endlessly, eating up system
> resources until it finally dumps core.


> I have no idea how ~/.fonts.cache-2.bad was created.

I was experiencing a similar problem and tried to reproduce it all
yesterday afternoon[1].  My problem was as follows:

1. make clean; make; make install
2. rm /var/cache/fontconfig/*
3. fc-list
4. fc-list

The second fc-list used to loop.  But it doesn't seem to loop anymore.
I then tried to trace down the commit that made it not loop, but didn't
succeed, which makes me a bit suspicious.  I'll putz around with it a
bit more today, but I suspect that it is gone.  Hopefully I can figure
out which commit fixed it.


[1] I seem to lack sufficient amounts of CVS-fu to make it really easy
to binary search on a branch; cvs diff -rfc-2_4_branch -D2006-02-04
doesn't have the desired effect.  SVN is kind of better that way...
Fontconfig mailing list

[Index of Archives]     [Fedora Fonts]     [Fedora Users]     [Fedora Cloud]     [Kernel]     [Fedora Packaging]     [Fedora Desktop]     [PAM]     [Gimp Graphics Editor]     [Yosemite News]

  Powered by Linux