[PATCH 00/11] Cleanup zbd code

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



The patch series cleans up zbd.c code, improving code readability.      
Overall, no functional change is introduced.

Damien Le Moal (11):
  fio: Improve documentation of ignore_zone_limits option
  zbd: define local functions as static
  zbd: move and cleanup code
  zbd: remove is_zone_open() helper
  zbd: introduce zbd_verify_file_sizes()
  zbd: fix code style issues
  zbd: simplify zbd_close_zone()
  zbd: simplify zbd_open_zone()
  zbd: rename zbd_zone_idx() and zbd_zone_nr()
  zbd: rename get_zone()
  zbd: introduce zbd_get_zone_from_offset() helper

 HOWTO |   6 +
 fio.1 |   6 +-
 zbd.c | 960 +++++++++++++++++++++++++++++++---------------------------
 3 files changed, 524 insertions(+), 448 deletions(-)

-- 
2.31.1




[Index of Archives]     [Linux Kernel]     [Linux SCSI]     [Linux IDE]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux SCSI]

  Powered by Linux