From: Niklas Cassel <niklas.cassel@xxxxxxx> Hello Jens, Here is a cleanup series that improves the cmdprio_percentage and cmdprio_bssplit options in libaio and io_uring ioengines. I'm currently working on adding support for multiple priority class + priority level combinations, however that series is not quite ready yet. Getting this cleanup series merged would make it easier to get multiple priority class + priority level combinations added. (Because AFAICT we wouldn't need any further changes to engines/io_uring.c or engines/libaio.c after this. Most changes will be to cmdprio.c and stat.c.) Changes since v2: -Incorporated review comments by Damien. -Picked up Reviewed-by tags. Kind regards, Niklas Niklas Cassel (8): docs: update cmdprio_percentage documentation cmdprio: move cmdprio function definitions to a new cmdprio.c file cmdprio: do not allocate memory for unused data direction io_uring: set async IO priority to td->ioprio in fio_ioring_prep() libaio,io_uring: rename prio_prep() to include cmdprio in the name libaio,io_uring: move common cmdprio_prep() code to cmdprio cmdprio: add mode to make the logic easier to reason about libaio,io_uring: make it possible to cleanup cmdprio malloced data HOWTO | 5 +- Makefile | 6 ++ engines/cmdprio.c | 243 +++++++++++++++++++++++++++++++++++++++++++++ engines/cmdprio.h | 150 +++++----------------------- engines/io_uring.c | 100 ++++++------------- engines/libaio.c | 72 +++++--------- fio.1 | 3 +- 7 files changed, 332 insertions(+), 247 deletions(-) create mode 100644 engines/cmdprio.c -- 2.33.1