[Fedora Rawhide][x86 MacBook] Can’t boot after dnf system-upgrade 39 to Rawhide

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



I wanted to test Fedora Rawhide so I ran `dnf system-upgrade download --releasever rawhide --exclude=sdubby` (as per https://bugzilla.redhat.com/show_bug.cgi?id=2243872#c12) to upgrade from Fedora 39 and it finished successfully. However after I ran `dnf system-upgrade reboot` and got a black screen after the system upgrade progress bar. And I can no longer boot into the Fedora partition and only get a black screen. Before that, I was able to use Fedora 39 alongside macOS just fine.

Has anyone been able to run Rawhide on an x86 MacBook Pro (2016) or a similar x86 Mac* device? And what can I do to further investigate the boot issue?

Note: I noticed that after the upgrade, the name in the mac boot menu changed from “Fedora” to “UEFI Boot” and the symbol is still the Fedora logo, not sure what this means. So could it be the efibootmgr-related bug that was recently fixed in the Fedora 39 nightly ISO (https://bugzilla.redhat.com/show_bug.cgi?id=2239316)?

Note 2: I also couldn't go past the initial menu when I used the Fedora Rawhide ISO a few days ago (around Oct 10 iirc), not sure if this is related.


test mailing list -- test@xxxxxxxxxxxxxxxxxxxxxxx
To unsubscribe send an email to test-leave@xxxxxxxxxxxxxxxxxxxxxxx
Fedora Code of Conduct: https://docs.fedoraproject.org/en-US/project/code-of-conduct/
List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines
List Archives: https://lists.fedoraproject.org/archives/list/test@xxxxxxxxxxxxxxxxxxxxxxx
Do not reply to spam, report it: https://pagure.io/fedora-infrastructure/new_issue

[Index of Archives]     [Fedora Desktop]     [Fedora SELinux]     [Photo Sharing]     [Yosemite Forum]     [KDE Users]

  Powered by Linux