[Bug 1837107] Review Request: 7kaa - Seven Kingdoms: Ancient Adversaries (claiming ownership of package)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



https://bugzilla.redhat.com/show_bug.cgi?id=1837107

Dominik 'Rathann' Mierzejewski <dominik@xxxxxxxxxxxxxx> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |dominik@xxxxxxxxxxxxxx



--- Comment #1 from Dominik 'Rathann' Mierzejewski <dominik@xxxxxxxxxxxxxx> ---
BuildRequires:  gcc-c++
BuildRequires: SDL2-devel, SDL2_net-devel
BuildRequires: enet-devel
BuildRequires: openal-soft-devel, autoconf
BuildRequires: gettext-devel
BuildRequires: desktop-file-utils
BuildRequires: ImageMagick
BuildRequires: libcurl-devel
BuildRequires: automake

It is a matter of taste, but I'd put one dependency per line and sort
alphabetically.
It's easier to follow and makes diffs smaller in case of dependency changes.

%postun music
if [ $1 -eq 0 ] ; then
## When Uninstall
    rm -fr %{prj_music_dir}
fi

This is unnecessary (and rpmlint warns about it being dangerous).
You can get the list of files that autodownloader will download and include it
with %ghost marker instead.

cd /tmp/%{name}-music
tar xjvf /tmp/%{name}-music/%{name}-music.tar.bz2
sudo install -v -m 644 /tmp/%{name}-music/%{name}-music/music/*
%{_datadir}/%{name}/music
sudo install -v -m 644 /tmp/%{name}-music/%{name}-music/*.txt
%{_docdir}/%{name}-music

This should use mktemp instead of a hard-coded directory name.
Moreover, /tmp is an in-memory file system and may not have enough space.
mktemp -p /var/tmp -d looks like a good solution here.
Also, you should not assume that sudo will be configured.


-- 
You are receiving this mail because:
You are on the CC list for the bug.
You are always notified about changes to this product and component
_______________________________________________
package-review mailing list -- package-review@xxxxxxxxxxxxxxxxxxxxxxx
To unsubscribe send an email to package-review-leave@xxxxxxxxxxxxxxxxxxxxxxx
Fedora Code of Conduct: https://docs.fedoraproject.org/en-US/project/code-of-conduct/
List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines
List Archives: https://lists.fedoraproject.org/archives/list/package-review@xxxxxxxxxxxxxxxxxxxxxxx




[Index of Archives]     [Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite Conditions]     [KDE Users]

  Powered by Linux