Hi folks, I'm working on adding btf__dedup() support to pahole when doing DWARF to BTF conversion, which requires usage of libbpf from pahole. I've already added libbpf as a submodule and pahole now reuses btf.h header with all the btf struct definitions. Next step is actually using btf__dedup(). The problem with that is that both libbpf and pahole define their own incompatible versions of struct btf, which causes a lot of naming conflicts when I'm trying to use libbpf along those structs. Pahole has it's own internal library centered around struct btf with lots of useful methods to manipulate BTF data. My intent is to migrate most of that functionality (e.g., pretty-printing and BTF types construction) into libbpf, so maybe in the future pahole won't need it's own struct btf, but for now I'd like to avoid blocking on that. So to make progress I'll need to rename pahole's struct btf into something else. And I've been struggling to come up with good succinct name. The best I've got so far is btf_info, but I can't say I'm too happy with it. So consider this email a solicitation for naming suggestion. Keep in mind, that all the pahole's functions of the form btf__xxx will be renamed as well for consistency. If you like btf_info, let me know as well, I'll just stick with it. -- Andrii