Hi Dave, More drm-misc for 4.4. - fb refcount fix in atomic fbdev - various locking reworks to reduce drm_global_mutex and dev->struct_mutex - rename docbook to gpu.tmpl and include vga_switcheroo stuff, plus more vga_switcheroo (Lukas Wunner) - viewport check fixes for atomic drivers from Ville - DRM_DEBUG_VBL from Ville - non-contentious header fixes from Mikko Rapeli - small things all over Cheers, Daniel The following changes since commit b44f84081b8db1b5830cbd30280ba1109cc1a084: drm: Stop using drm_vblank_count() as the hw frame counter (2015-10-07 16:13:52 +0200) are available in the git repository at: git://anongit.freedesktop.org/drm-intel tags/topic/drm-misc-2015-10-19 for you to fetch changes up to a0fb6ad7ae28a4dce34c010028dc070eeacae1d9: drm/fb-helper: Fix fb refcounting in pan_display_atomic (2015-10-19 11:00:48 +0200) ---------------------------------------------------------------- Adam Richter (1): drm: fix mutex leak in drm_dp_get_mst_branch_device Daniel Vetter (11): drm/i915: Mark getparam ioctl as DRM_UNLOCKED drm: Enforce unlocked ioctl operation for kms driver ioctls drm/<drivers>: Drop DRM_UNLOCKED from modeset drivers drm/doc: Rename docbook to gpu.tmpl drm/gem: Drop struct_mutex requirement from drm_gem_mmap_obj drm/gem: Check locking in drm_gem_object_unreference drm/gem: Use container_of in drm_gem_object_free drm/vgem: Drop vgem_drm_gem_mmap drm/gem: Use kref_get_unless_zero for the weak mmap references drm/fb-helper: Set plane rotation directly drm/fb-helper: Fix fb refcounting in pan_display_atomic Lukas Wunner (8): vga_switcheroo: Use enum vga_switcheroo_state instead of int vga_switcheroo: Use VGA_SWITCHEROO_UNKNOWN_ID instead of -1 vga_switcheroo: Use enum vga_switcheroo_client_id instead of int gpu/doc: Fix up remaining occurrences of old document title gpu/doc: Add vga_switcheroo documentation gpu/doc: Convert to markdown harder drm: Fix return value of drm_framebuffer_init() ALSA: hda - Spell vga_switcheroo consistently Mikko Rapeli (3): savage_drm.h: include <drm/drm.h> r128_drm.h: include drm/drm.h drm/i810_drm.h: include drm/drm.h Rob Clark (1): drm: misc cleanup Ville Syrjälä (7): drm: Don't use '\' for string literal concatenation drm: Add DRM_DEBUG_VBL() drm: Don't leak fb when plane crtc coodinates are bad drm: Swap w/h when converting the mode to src coordidates for a rotated primary plane drm: Refactor plane src coordinate checks drm: Check crtc viewport correctly with rotated primary plane on atomic drivers drm: Check plane src coordinates correctly during page flip for atomic drivers Documentation/DocBook/Makefile | 2 +- Documentation/DocBook/{drm.tmpl => gpu.tmpl} | 94 ++++++++++++++++++++++++---- drivers/gpu/drm/amd/amdgpu/amdgpu_kms.c | 24 +++---- drivers/gpu/drm/armada/armada_drv.c | 9 +-- drivers/gpu/drm/drm_atomic_helper.c | 9 ++- drivers/gpu/drm/drm_crtc.c | 81 +++++++++++++----------- drivers/gpu/drm/drm_dp_mst_topology.c | 7 ++- drivers/gpu/drm/drm_drv.c | 4 +- drivers/gpu/drm/drm_fb_helper.c | 35 ++++++++--- drivers/gpu/drm/drm_gem.c | 47 +++++++++----- drivers/gpu/drm/drm_gem_cma_helper.c | 2 - drivers/gpu/drm/drm_ioctl.c | 10 ++- drivers/gpu/drm/drm_irq.c | 26 ++++---- drivers/gpu/drm/drm_vma_manager.c | 40 ++++-------- drivers/gpu/drm/exynos/exynos_drm_drv.c | 20 +++--- drivers/gpu/drm/i915/i915_dma.c | 70 ++++++++++----------- drivers/gpu/drm/msm/msm_drv.c | 14 ++--- drivers/gpu/drm/msm/msm_fbdev.c | 5 -- drivers/gpu/drm/msm/msm_gem_prime.c | 2 - drivers/gpu/drm/nouveau/nouveau_drm.c | 24 +++---- drivers/gpu/drm/omapdrm/omap_crtc.c | 3 - drivers/gpu/drm/omapdrm/omap_drv.c | 12 ++-- drivers/gpu/drm/omapdrm/omap_gem_dmabuf.c | 3 - drivers/gpu/drm/qxl/qxl_ioctl.c | 14 ++--- drivers/gpu/drm/radeon/radeon_kms.c | 30 ++++----- drivers/gpu/drm/rockchip/rockchip_drm_gem.c | 3 - drivers/gpu/drm/tegra/drm.c | 28 ++++----- drivers/gpu/drm/vgem/vgem_drv.c | 55 +--------------- drivers/gpu/drm/vmwgfx/vmwgfx_drv.c | 54 ++++++++-------- drivers/gpu/vga/vga_switcheroo.c | 36 ++++++----- include/drm/drmP.h | 11 +++- include/drm/drm_crtc.h | 5 -- include/drm/drm_gem.h | 5 +- include/drm/drm_vma_manager.h | 24 +++---- include/linux/vga_switcheroo.h | 14 +++-- include/uapi/drm/i810_drm.h | 2 + include/uapi/drm/r128_drm.h | 2 + include/uapi/drm/savage_drm.h | 2 + sound/pci/hda/hda_controller.h | 2 +- sound/pci/hda/hda_intel.c | 12 ++-- sound/pci/hda/hda_intel.h | 2 +- 41 files changed, 443 insertions(+), 401 deletions(-) rename Documentation/DocBook/{drm.tmpl => gpu.tmpl} (98%) -- Daniel Vetter Software Engineer, Intel Corporation http://blog.ffwll.ch _______________________________________________ dri-devel mailing list dri-devel@xxxxxxxxxxxxxxxxxxxxx http://lists.freedesktop.org/mailman/listinfo/dri-devel