On Thu, Mar 5, 2015 at 5:14 AM, Oded Gabbay <oded.gabbay@xxxxxxx> wrote: > fence_wait_timeout() is an exported kernel symbol, so we should rename our > local function to something different. > > Signed-off-by: Oded Gabbay <oded.gabbay@xxxxxxx> Reviewed-by: Alex Deucher <alexander.deucher@xxxxxxx> > --- > drivers/gpu/drm/amd/amdkfd/kfd_device_queue_manager.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/drivers/gpu/drm/amd/amdkfd/kfd_device_queue_manager.c b/drivers/gpu/drm/amd/amdkfd/kfd_device_queue_manager.c > index b3589d0..b508bae 100644 > --- a/drivers/gpu/drm/amd/amdkfd/kfd_device_queue_manager.c > +++ b/drivers/gpu/drm/amd/amdkfd/kfd_device_queue_manager.c > @@ -891,7 +891,7 @@ out: > return retval; > } > > -static int fence_wait_timeout(unsigned int *fence_addr, > +static int amdkfd_fence_wait_timeout(unsigned int *fence_addr, > unsigned int fence_value, > unsigned long timeout) > { > @@ -947,7 +947,7 @@ static int destroy_queues_cpsch(struct device_queue_manager *dqm, bool lock) > pm_send_query_status(&dqm->packets, dqm->fence_gpu_addr, > KFD_FENCE_COMPLETED); > /* should be timed out */ > - fence_wait_timeout(dqm->fence_addr, KFD_FENCE_COMPLETED, > + amdkfd_fence_wait_timeout(dqm->fence_addr, KFD_FENCE_COMPLETED, > QUEUE_PREEMPT_DEFAULT_TIMEOUT_MS); > pm_release_ib(&dqm->packets); > dqm->active_runlist = false; > -- > 2.1.0 > > _______________________________________________ > dri-devel mailing list > dri-devel@xxxxxxxxxxxxxxxxxxxxx > http://lists.freedesktop.org/mailman/listinfo/dri-devel _______________________________________________ dri-devel mailing list dri-devel@xxxxxxxxxxxxxxxxxxxxx http://lists.freedesktop.org/mailman/listinfo/dri-devel